[Interest] Error when compiling Qt 5.5.0 beta for Max OS X 10.8

Calogero Mauceri mauceri at actgate.com
Thu Jun 18 12:07:38 CEST 2015

Il 6/18/2015 12:01 PM, Sorvig Morten ha scritto:
>> On 18 Jun 2015, at 10:58, Calogero Mauceri <mauceri at actgate.com> wrote:
>> Il 5/20/2015 12:39 PM, Sorvig Morten ha scritto:
>>>> On 19 May 2015, at 10:50, Calogero Mauceri <mauceri at actgate.com> wrote:
>>>> Hi all,
>>>> I'm trying to compile Qt 5.5.0 beta for Mac OS X 10.8, on Mac OS X 10.10.
>>>> qxctestlogger.mm:129:27: error: property 'description' not found on
>>>> object of
>>>>        type 'id'
>>>>              [NSDate date].description.UTF8String);
>>>> Is this a bug or am I doing something wrong?
>>> It’s a bug! Fixing is in progress, see
>>> 	https://codereview.qt-project.org/#/c/112440/
>>> Morten
>> It seems this fix was not included in the RC. I'm still getting the same error when compiling 5.5.0 RC for Mac OS X 10.8.
> Looks like the fix was committed for the 5.5 branch after 5.5.0 was branched off it. That means it will be released with Qt 5.5.1.
> Morten
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest


Shouldn't the minimum OS X platform supported by Qt 5.5.0 be Mac OS X 
10.8? If this does not get fixed it will not compile there (unless of 
course you don't manually patch it yourself).
The fix is very simple, is there no way to bring it in current release 


Calogero Mauceri
Software Engineer

Applied Coherent Technology Corporation (ACT)

More information about the Interest mailing list