[Interest] Release build Errors on launch in android - used to work fine

Jason H jhihn at gmx.com
Tue Apr 26 15:31:26 CEST 2016

I have a project that I've been working on for a while now. Yesterday something went wonky, and I did a clean, then build. The debug version works fine, but the release crashes on app start with the following errors:

E/art     (  556): dlopen("/data/data/com.company.app.a/qt-reserved-files/plugins/bearer/libqandroidbearer.so", RTLD_LAZY) failed: dlopen failed: could not load library "libQt5Network.so" needed by "libqandroidbearer.so"; caused by library "libQt5Network.so" not found


E/AndroidRuntime(  556): No implementation found for void com.company.app.MyActivity.didBecomeActive() (tried Java_com_company_app_MyActivity_didBecomeActive and Java_com_company_app_MyActivity_didBecomeActive__)

extern "C" {
                      //(tried Java_com_company_app_MyActivity_didBecomeActive // MATCHES
	JNIEXPORT void JNICALL Java_com_company_app_MyActivity_didBecomeActive(JNIEnv* env, jobject jo)

		qDebug() << Q_FUNC_INFO;
		if (PlatformShimImpl::instance())

I'd really like to be able to build a release build.

More information about the Interest mailing list