[Interest] Qt + Android + OpenSSL

Konstantin Tokarev annulen at yandex.ru
Mon Apr 15 21:00:27 CEST 2019



15.04.2019, 21:16, "Nuno Santos" <nunosantos at imaginando.pt>:
> Hi,
>
> I’m trying to use SSL websocket on a Qt 5.12 Android app.
>
> When I run the app it is complaining about the missing functions.
>
> W qt.network.ssl: QSslSocket: cannot resolve DTLSv1_2_server_method
> W qt.network.ssl: QSslSocket: cannot resolve DTLSv1_2_client_method
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CONF_CTX_new
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CONF_CTX_free
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CONF_CTX_set_ssl_ctx
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CONF_CTX_set_flags
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CONF_CTX_finish
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CONF_cmd
> W qt.network.ssl: QSslSocket: cannot resolve SSL_set_alpn_protos
> W qt.network.ssl: QSslSocket: cannot resolve SSL_CTX_set_alpn_select_cb
> W qt.network.ssl: QSslSocket: cannot resolve SSL_get0_alpn_selected
> W qt.network.ssl: QSslSocket: cannot resolve DTLS_server_method
> W qt.network.ssl: QSslSocket: cannot resolve DTLS_client_method
> W qt.network.ssl: QSslSocket: cannot call unresolved function DTLS_client_method

Note that these warning messages don't necessary mean a problem for you.
For examples, if your application doesn't use DTLS or HTTP/2 protocol negotiation
you can ignore DTLS and ALPN warnings.

> I’m providing OpenSSL 1.0.1s as an ANDROID_EXTRA_LIBS param.
>
> Does anybody know if the problem here is the fact that OpenSSL is too old?
>
> Thanks in advance!
>
> Regards,
>
> Nuno
> ,
>
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> https://lists.qt-project.org/listinfo/interest


-- 
Regards,
Konstantin


More information about the Interest mailing list