[Interest] Qt free software policy

Roland Hughes roland at logikalsolutions.com
Wed Aug 14 21:09:02 CEST 2019


If you do not need the latest bells and whistles, drop back to Qt 4.8

https://doc.qt.io/archives/qt-4.8/opensourceedition.html

That version is rather prominent in the medical device world, because of 
the issues you bring up here.

On 8/14/19 1:36 PM, David M. Cotter wrote:
> +1 on this
>
> i am in the process of porting my legacy project to Qt and am afraid that i’ve made the wrong choice.  i’m just one guy and i bet my whole business on the availability of what  i need from Qt under LGPL
>
> i’m already using a third party HTTP server so i’m not affected by this but it’s a worrying sign. I too agree that the HTTP server really should be LGPL.
>
> What’s going to happen? It’s taken me over a year’s worth of work to get this far with Qt and i’m only half done. did i make the wrong choice?
>
> -dave

-- 
Roland Hughes, President
Logikal Solutions
(630)-205-1593  (cell)
http://www.theminimumyouneedtoknow.com
http://www.infiniteexposure.net
http://www.johnsmith-book.com



More information about the Interest mailing list