[Interest] Building Qt from Git: Information on version of external libraries

Thiago Macieira thiago.macieira at intel.com
Thu Aug 22 17:38:38 CEST 2019


On Thursday, 22 August 2019 07:19:09 PDT Rainer Wiesenfarth wrote:
> Hmm, yes and no. I fully agree that I should go as latest as possible, but
> if - like with ICU by the introduction of a namespace - the API has
> changed, the build will fail. I'd like to minimize those failing builds
> upfront... 

Qt 5.12 is sufficiently recent that all modern versions of everything still 
work. And 5.12.4 is the current LTS version, so you should expect Qt to keep 
up with updates of the APIs of the dependent libraries.

Where it is not possible, it's explicitly noted. Like Qt 5.9 not supporting 
OpenSSL 1.1.

-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products





More information about the Interest mailing list