[Interest] Qt 5.9 and OpenSSL 1.1?

Thiago Macieira thiago.macieira at intel.com
Fri Mar 22 03:11:58 CET 2019


On Wednesday, 20 March 2019 23:45:38 PDT Roland Winklmeier wrote:
> Wouldn’t it be good then if official binaries from newer releases build
> against OpenSSL 1.1?

Yes and no. For future compatibility, we should do that and should have done 
that for 5.12 already. But doing so means the binaries so produced won't run 
on older, still supported Linux distributions.

> According to
> https://wiki.qt.io/Qt_5.12_Tools_and_Versions all official binaries are
> still built against 1.0.2. If that is end of live this year, is there a
> plan to change this?

Not yet. Thanks for bringing it up, we'll have to make a decision. I'll bring 
this up with the release team to figure out if there's a limitation in the 
build servers (if it's the same environment that builds 5.9, for example). 
Then we'll make a recommendation.

-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel System Software Products





More information about the Interest mailing list