[Interest] Qt 5.9 and OpenSSL 1.1?

René J. V. Bertin rjvbertin at gmail.com
Fri Mar 22 11:15:45 CET 2019


Thiago Macieira wrote:

> openSUSE has it:
> https://build.opensuse.org/package/show/openSUSE:Leap:15.1:Update/libqt5-qtbase
> 
> But I recommend finding the other ones to see if any of them missed any
> backported fix.

Thanks, will try to see if Arch has one too (their equivalent for Qt4 didn't 
apply cleanly though).

Curious patch I see in Leap:
https://build.opensuse.org/package/view_file/openSUSE:Leap:15.1:Update/libqt5-qtbase/0001-Revert-Fail-faster-on-OpenSSL-1.1.patch?expand=1

Isn't there a specific config.tests/unix/openssl11/openssl.cpp test which is 
supposed to succeed while config.tests/openssl/openssl.cpp should fail against 
openssl 1.1 ? Or am I somehow missing the mentioned revert in the 5.10 branch?

R



More information about the Interest mailing list