[Interest] Build problems, Android app on Qt 5.12.2

Jason H jhihn at gmx.com
Tue Mar 26 11:35:04 CET 2019


Whenever I've seen that, it's been an issue with config/install path.

For example you're saying API 28, but you're clearly referencing 29

> Sent: Monday, March 25, 2019 at 10:01 PM
> From: "Nelson, Michael" <mnelson at sutron.com>
> To: "interest at qt-project.org" <interest at qt-project.org>
> Subject: [Interest] Build problems, Android app on Qt 5.12.2
>
> Questions:
> 1) What successful tool sets are working for others to build Qt apps for Android?
> 2) Any idea what might be causing the following problem?
>
> Using these tools:
>    Qt 5.12.2
>    Android SDK 28
>    Android SDK Tools 26.1.1
>    Android NDK r19c
>    Java jdk1.8.0_172
>
> androiddeployqt fails:
>
> :compileDebugAidl FAILED
>
> FAILURE: Build failed with an exception.
>
> * What went wrong:
> Execution failed for task ':compileDebugAidl'.
> > java.io.IOException: com.android.ide.common.process.ProcessException: Error while executing process C:\Users\nelson\AppData\Local\Android\Sdk\build-tools\29.0.0-rc1\aidl.exe with arguments ...
>
> Thanks,
> Mike
>
> Please be advised that this email may contain confidential information. If you are not the intended recipient, please notify us by email by replying to the sender and delete this message. The sender disclaims that the content of this email constitutes an offer to enter into, or the acceptance of, any agreement; provided that the foregoing does not invalidate the binding effect of any digital or other electronic reproduction of a manual signature that is included in any attachment.
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> https://lists.qt-project.org/listinfo/interest
>


More information about the Interest mailing list