[Interest] QFile/QDir: force move mode only?

d3fault d3faultdotxbe at gmail.com
Tue May 14 04:11:57 CEST 2019

On 5/13/19, Bernhard Lindner <private at bernhard-lindner.de> wrote:
>> QFile::rename should rename always or fail! It should never do
>> completely different operation - copy!
> I agree.

Adding a non-copying rename method to QFile/etc seems justified. Maybe
call it: fastRename, tryRename, or atomicRename?


More information about the Interest mailing list