[Interest] New error building Qt 5.13 on CentOS 6

Simon Matthews simon.matthews at bluepearlsoftware.com
Thu Oct 31 00:32:08 CET 2019


I have been working on issues relating to qtwebengine, but when I
started from scratch again, I got this new error message. Does anyone
have any idea what's going on:

ar cqs ../../../../../lib/libxcb-static.a .obj/xfixes.o .obj/randr.o
.obj/shm.o .obj/sync.o .obj/render.o .obj/shape.o .obj/xkb.o
.obj/xinerama.o .obj/xinput.o .obj/xcb_aux.o .obj/atoms.o .obj/event.o
.obj/xcb_image.o .obj/keysyms.o .obj/util.o .obj/icccm.o
make[6]: Leaving directory
'/home/simon/rpms/sources/qt-build/qtbase/src/plugins/platforms/xcb/xcb-static'
( test -e Makefile.xcb_qpa_lib ||
/home/simon/rpms/sources/qt-build/qtbase/bin/qmake -o
Makefile.xcb_qpa_lib
/home/simon/rpms/sources/qt-everywhere-src-5.13.1/qtbase/src/plugins/platforms/xcb/xcb_qpa_lib.pro
) && make -f Makefile.xcb_qpa_lib
Project ERROR: Unknown module(s) in QT: xkbcommon_support-private
make[5]: *** [Makefile:90: sub-xcb_qpa_lib-pro-make_first-ordered] Error 3
make[5]: Leaving directory
'/home/simon/rpms/sources/qt-build/qtbase/src/plugins/platforms/xcb'
make[4]: *** [Makefile:103: sub-xcb-make_first] Error 2
make[4]: Leaving directory
'/home/simon/rpms/sources/qt-build/qtbase/src/plugins/platforms'
make[3]: *** [Makefile:105: sub-platforms-make_first] Error 2
make[3]: Leaving directory
'/home/simon/rpms/sources/qt-build/qtbase/src/plugins'
make[2]: *** [Makefile:777: sub-plugins-make_first] Error 2
make[2]: Leaving directory '/home/simon/rpms/sources/qt-build/qtbase/src'
make[1]: *** [Makefile:51: sub-src-make_first] Error 2
make[1]: Leaving directory '/home/simon/rpms/sources/qt-build/qtbase'
make: *** [Makefile:81: module-qtbase-make_first] Error 2


Configure command:

/home/simon/rpms/sources/qt-everywhere-src-5.13.1/qtbase/configure
-top-level -v -R
\\$$ORIGIN/lib:\\$$ORIGIN:\\$$ORIGIN/../lib:\\$$ORIGIN/../../lib
-opensource -qt-libpng -qt-zlib -qt-libjpeg -nomake examples -sql-sqlite
-confirm-license -prefix /opt/BP_test -widgets -skip activeqt -skip
androidextras -skip connectivity -skip macextras -skip serialport -icu
-fontconfig -no-reduce-relocations -qt-xcb -system-proxies
-no-pulseaudio -no-alsa -no-mtdev -dbus -qt-pcre -no-libudev -no-openssl
-no-xcb-xinput -webengine-embedded-build -no-webengine-alsa
-webengine-printing-and-pdf -webengine-pepper-plugins
-no-webengine-pulseaudio -no-webengine-alsa
-no-webengine-printing-and-pdf -no-webengine-pepper-plugins -no-evdev
WEBENGINE_FREETYPE_INCDIR=/opt/BP/include/
QMAKE_CXXFLAGS=-I/opt/BP/include/freetype2 -I/opt/BP/include/glib-2.0
QMAKE_LIBS_FREETYPE=/opt/BP/lib/libfreetype.so

I am using devtoolset-8:
gcc version 8.3.1 20190311 (Red Hat 8.3.1-3) (GCC)

and python 2.7:

$ python -V
Python 2.7.16

Simon
Blue Pearl Software, Inc. will collect and process information about you that may be subject to data protection laws. For more information about how we use and disclose your personal information, how we protect your information, our legal basis to use your information, your rights and who you can contact, please refer to the relevant sections of our Privacy note at www.bluepearlsoftware.com/privacypolicy.


More information about the Interest mailing list