[Interest] Qt permanently broke on computer

Jason H jhihn at gmx.com
Mon Apr 26 17:10:50 CEST 2021

> Sent: Monday, April 26, 2021 at 11:01 AM
> From: "Jason H" <jhihn at gmx.com>
> To: "Jason H" <jhihn at gmx.com>
> Cc: "interestqt-project.org" <interest at qt-project.org>
> Subject: Re: [Interest] Qt permanently broke on computer
> > I tried to port an app on a Win10 PC. That went well. Then I tried to deploy (windeployqt) it.
> >
> > Now when I run it in creator I get:
> > 10:26:28: Starting C:\Users\Admin\Projects\build-phidget-spinner-Desktop_Qt_5_15_2_MinGW_64_bit-Debug\debug\phidget-spinner.exe ...
> > qt.qpa.plugin: Could not find the Qt platform plugin "windows" in ""
> >
> > I have deleted the C:\Qt dir and re-installed.
> > I have cleaned the app source dir and deleted the shadow build dirs, deleted the .pro.user file,
> > I launched QtC from the start menu.
> >
> > I have no idea how to get this working again.
> Some additional info:
> Other projects work.
> The crash is in this statement:
> QGuiApplication app(argc, argv);
> the stack indicates a crash starting at:
> QGuiApplicationPrivate::createPlatformIntegration()
> All the online help (stackexchange) seems to be about deployment, but I'm just trying to run it in creator.

Update #2:

The same thing happens on a totaly new computer, never had qt on it before, installed Qt, copied the source and built it, some error.

More information about the Interest mailing list