[Interest] Svar: Qt permanently broke on computer

Andy Shaw andy.shaw at qt.io
Mon Apr 26 20:47:07 CEST 2021

What is also useful to check is to set QT_DEBUG_PLUGINS=1 as your environment variable, it can tell you where it is looking for the plugin then. Maybe it finds a qt.conf file and it is influencing the paths incorrectly there.


Fra: Interest <interest-bounces at qt-project.org> på vegne av Jérôme Godbout <godboutj at amotus.ca>
Dato: mandag, 26. april 2021 kl. 19:33
Til: Jason H <jhihn at gmx.com>
Kopi: interestqt-project.org <interest at qt-project.org>
Emne: Re: [Interest] Qt permanently broke on computer
You might try to delete the .user files for the project and clean the build folder manually (erase the whole folder). Check the project config to spot any differences there. If some project work with the same Qt version, the Qt install is probably good. Make sure all you dependencies are ok.

From: Interest <interest-bounces at qt-project.org> on behalf of Jason H <jhihn at gmx.com>
Date: Monday, April 26, 2021 at 11:11 AM
To: Jason H <jhihn at gmx.com>
Cc: interestqt-project.org <interest at qt-project.org>
Subject: Re: [Interest] Qt permanently broke on computer

> Sent: Monday, April 26, 2021 at 11:01 AM
> From: "Jason H" <jhihn at gmx.com>
> To: "Jason H" <jhihn at gmx.com>
> Cc: "interestqt-project.org" <interest at qt-project.org>
> Subject: Re: [Interest] Qt permanently broke on computer
> > I tried to port an app on a Win10 PC. That went well. Then I tried to deploy (windeployqt) it.
> >
> > Now when I run it in creator I get:
> > 10:26:28: Starting C:\Users\Admin\Projects\build-phidget-spinner-Desktop_Qt_5_15_2_MinGW_64_bit-Debug\debug\phidget-spinner.exe ...
> > qt.qpa.plugin: Could not find the Qt platform plugin "windows" in ""
> >
> > I have deleted the C:\Qt dir and re-installed.
> > I have cleaned the app source dir and deleted the shadow build dirs, deleted the .pro.user file,
> > I launched QtC from the start menu.
> >
> > I have no idea how to get this working again.
> Some additional info:
> Other projects work.
> The crash is in this statement:
> QGuiApplication app(argc, argv);
> the stack indicates a crash starting at:
> QGuiApplicationPrivate::createPlatformIntegration()
> All the online help (stackexchange) seems to be about deployment, but I'm just trying to run it in creator.

Update #2:

The same thing happens on a totaly new computer, never had qt on it before, installed Qt, copied the source and built it, some error.
Interest mailing list
Interest at qt-project.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20210426/1988c60b/attachment.html>

More information about the Interest mailing list