[Interest] Qt permanently broke on computer

Andrei Golubev andrei.golubev at qt.io
Wed Apr 28 10:34:33 CEST 2021

Hi Jason and everyone,

This looks like a typical issue with not found QPA [1] plugin to me. If you build from source, make sure that you really build *everything*. QPA plugins are dynamically loaded (hence, plugins) and do not explicitly link against any target (thus they are excluded from build dependencies) which means that if you build a specific part of Qt (e.g. only QtCore + QtGui + something else), they might not be built at all. I guess on windows you're looking for something called QWindowsIntergrationPlugin (see [1]).
If you build everything, then probably the discovery inside Qt couldn't find the plugin for some reason (you might want to experiment with PATH env var).

Also, feel free to add a bug report if the issue does not seem solvable (IIRC there's "QPA: Windows" component that you could use in the bug report). You also mention deployment, so maybe something goes wrong during that step.

[<https://doc.qt.io/qt-6/qpa.html>1] https://doc.qt.io/qt-6/qpa.html
Qt Platform Abstraction | Platform Integration 6.0.3<https://doc.qt.io/qt-6/qpa.html>
The Qt Platform Abstraction (QPA) is the main platform abstraction layer in Qt. The API can be identified by the QPlatform* class prefix, and is used for implementing higher level classes typically found in Qt GUI, e.g. QPlatformWindow for window system integration exposed through QWindow, or QPlatformTheme for deeper platform theming and integration, exposed through QStyleHint and QStyle.

Best Regards,
From: Interest <interest-bounces at qt-project.org> on behalf of J?r?me Godbout <godboutj at amotus.ca>
Sent: Monday, April 26, 2021 7:30 PM
To: Jason H <jhihn at gmx.com>
Cc: interestqt-project.org <interest at qt-project.org>
Subject: Re: [Interest] Qt permanently broke on computer

You might try to delete the .user files for the project and clean the build folder manually (erase the whole folder). Check the project config to spot any differences there. If some project work with the same Qt version, the Qt install is probably good. Make sure all you dependencies are ok.

From: Interest <interest-bounces at qt-project.org> on behalf of Jason H <jhihn at gmx.com>
Date: Monday, April 26, 2021 at 11:11 AM
To: Jason H <jhihn at gmx.com>
Cc: interestqt-project.org <interest at qt-project.org>
Subject: Re: [Interest] Qt permanently broke on computer

> Sent: Monday, April 26, 2021 at 11:01 AM
> From: "Jason H" <jhihn at gmx.com>
> To: "Jason H" <jhihn at gmx.com>
> Cc: "interestqt-project.org" <interest at qt-project.org>
> Subject: Re: [Interest] Qt permanently broke on computer
> > I tried to port an app on a Win10 PC. That went well. Then I tried to deploy (windeployqt) it.
> >
> > Now when I run it in creator I get:
> > 10:26:28: Starting C:\Users\Admin\Projects\build-phidget-spinner-Desktop_Qt_5_15_2_MinGW_64_bit-Debug\debug\phidget-spinner.exe ...
> > qt.qpa.plugin: Could not find the Qt platform plugin "windows" in ""
> >
> > I have deleted the C:\Qt dir and re-installed.
> > I have cleaned the app source dir and deleted the shadow build dirs, deleted the .pro.user file,
> > I launched QtC from the start menu.
> >
> > I have no idea how to get this working again.
> Some additional info:
> Other projects work.
> The crash is in this statement:
> QGuiApplication app(argc, argv);
> the stack indicates a crash starting at:
> QGuiApplicationPrivate::createPlatformIntegration()
> All the online help (stackexchange) seems to be about deployment, but I'm just trying to run it in creator.

Update #2:

The same thing happens on a totaly new computer, never had qt on it before, installed Qt, copied the source and built it, some error.
Interest mailing list
Interest at qt-project.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20210428/e824853f/attachment.html>

More information about the Interest mailing list