[Interest] Installer Error with maintenance tool

mail at herrdiel.de mail at herrdiel.de
Sun Feb 7 23:21:08 CET 2021


I am trying to update to 5.15.2 (from 15.0) on a Win10-64 machine.
Maintenance tool gives me an installation error:

Execution failed (Unexpected exit code 2):
"C:\Qt\/Tools/QtCreator\bin\sdktool.exe addKit --id
qt.qt5.5152.win64_mingw81_kit --name Desktop Qt % {Qt:Version} MinGW
64-bit --Ctoolchain .gcc --Cxxtoolchain .g++ --qt
qt.qt5.5152.win64_mingw81 --debuggerid --devicetype Desktop"

What I've tried:
- I've checked the path: it seems to be ok, the "\/" part shouldn't make
a problem.
- I have manually granted full access/write permissions to everyone
throughout the entire tools folder.
- I have opened a command line (normal, elevated, gitBash yield the same
results) and tried to manually enter the command.

I've noticed two things: the --name argument seems to lack quotation
marks, it contains spaces and the  --debuggerid argument is missing.

Leaving the --debuggerid out and adding quotation marks for the --name I
get this error message:

Toolchain .gcc for language C does not exist.

Now, addkitoperation.cpp does expect an argument here.


if (current == "--debuggerid") {
            if (next.isNull())
                return false;
            ++i; // skip next;
            m_debuggerId = next;

Is that error message a bug? Or is it - as usually - a problem in my

What can I do to make the installation work properly?

Best Regards

http://www.classintouch.de - Tablet-Software für Lehrer

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20210207/a5122769/attachment.html>

More information about the Interest mailing list