Tamás Nagy tamas.nagy.001 at gmail.com
Mon May 15 18:25:31 CEST 2023


I tried to compile a complex project with Qt 5.14.0, which contains a
to GL\gl.h, so called Glut3 or OpenGL parts. The whole project compiles on
old computer. I tried to copy the CMakeList.txt based project on a new
After I installed config-pkg, it compiled with qtcreator without any errors
and I
was able to start it as a desktop program. Actually it has to be
and it also has a build-script.sh. So that is that it is running as a
desktop program
with the qtcreator is only a proof that it doesn't have any errors.

If I start the cross compilation with the build-script.sh, it throws random
errors containing: "QT_WARNING_DISABLE_DEPRECATED does not name a type",
"QT_INIT_METAOBJECT does not name a type" for the generated
moc_myprogram.cpp as the moc-compiler is running. Through the
cross-compilation script it comes to an error
that can be a missing library linkage. But in which .lib or .so are those
QT_WARNING_DISABLE_DEPRECATED? What should I add to the library linkage?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20230515/2f703a96/attachment.htm>

More information about the Interest mailing list