<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">Le mer. 14 août 2019 à 22:05, Thiago Macieira <<a href="mailto:thiago.macieira@intel.com">thiago.macieira@intel.com</a>> a écrit :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On Wednesday, 14 August 2019 12:17:44 PDT Benjamin TERRIER wrote:<br>
> The new add-ons modules could be provided as GPLv3 + GPLv2 + LGPLv3.<br>
<br>
Just a nitpick: there's no need to have GPL-3.0 and LGPL-3.0 at the same time. <br>
So the combinations are GPL-2.0+LGPL-3.0 and GPL-2.0+GPL-3.0.<br></blockquote><div><br></div><div>You are right.</div><div>However; the KDE agreement explicitly states that Qt add-ons must be available under GPLv3.</div><div>So I am wondering if there could be issues with licensing under LGPLv3 but not under GPLv3, even if for KDE it is equivalent.<br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
I don't know if there's anything that is GPL-3.0 (without 2.0). There may be.<br></blockquote><div><br></div><div>All recent and upcoming modules, except Qt 3D, are GPLv3, but not GPLv2.</div><div>The reason I started this thread is that I needed an http server for a Qt project under GPLv2,</div><div>I started to play with the QHttpServer (still work in progress, but working nice) until I realized</div><div>I would not be able to use it because it is GPLv3 only.</div><div><br></div><div>BR <br></div><div><br></div><div>Benjamin<br></div></div></div>