<div dir="ltr"><div>Which was actually a very, very bad surprise that was pretty poorly documented. Please don't do that again.</div><div><br></div><div>We saw the openssl change and didn't think anything big of it - well, it turned out that a minor upgrade to an TLS release completely broke secure web downloads, secure TLS connections, and our updater: so our software self-upgraded to a version it can't self-upgrade from. Horribly nasty experience all in all :( there should have been a bigger warning on this.<br></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Mon, Aug 19, 2019 at 2:06 AM Hamish Moffatt <<a href="mailto:hamish@risingsoftware.com">hamish@risingsoftware.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On 15/8/19 6:28 am, Thiago Macieira wrote:<br>
> PS: Qt 5.12 will switch to OpenSSL 1.1 in the binary builds. <br>
<br>
<br>
Indeed 5.12.4 already did.<br>
<br>
<br>
<br>
Hamish<br>
<br>
_______________________________________________<br>
Interest mailing list<br>
<a href="mailto:Interest@qt-project.org" target="_blank">Interest@qt-project.org</a><br>
<a href="https://lists.qt-project.org/listinfo/interest" rel="noreferrer" target="_blank">https://lists.qt-project.org/listinfo/interest</a><br>
</blockquote></div>