<div dir="ltr"><div dir="ltr">On Thu, Aug 22, 2019 at 4:07 PM Konstantin Tokarev <<a href="mailto:annulen@yandex.ru">annulen@yandex.ru</a>> wrote:<br></div><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">22.08.2019, 17:01, "Rainer Wiesenfarth" <<a href="mailto:rainer_wiesenfarth@trimble.com" target="_blank">rainer_wiesenfarth@trimble.com</a>>:<br>
> I am trying to build Qt (in my case: 5.12.4) from Git and came along the external ICU and OpenSSL libraries. Is there any page telling which version of the external libraries was used when building Qt?<br>
<br>
When building Qt from sources you should better use newest available version, e.g. 64.1 for ICU. It doesn't really matter what version is used in official binaries.<br></blockquote><div><br></div><div>Hmm, yes and no. I fully agree that I should go as latest as possible, but if - like with ICU by the introduction of a namespace - the API has changed, the build will fail. I'd like to minimize those failing builds upfront... :-)</div><div> </div><div>So, I'd like to have a page telling me "was build using versions ..." to have a safe fallback, and a base to judge if the latest version of an external library might work or not.</div><div><br></div><div>Cheers, Rainer</div></div></div>