[PySide] shiboken build issue with PythonLibs

John Ehresman jpe at wingware.com
Wed Sep 11 18:16:49 CEST 2013

On 9/10/13 6:55 PM, Amos Anderson wrote:
> Hello PySide list!
> I'm trying to compile PySide on an OSX 10.6 machine, but I run into a problem where shiboken is linking to a python symbol __PyTrash_thread_deposit_object which doesn't exist in the local python it's supposed to be linking against (the symbol __PyTrash_deposit_object exists there instead, c.f. the text pasted below). That is, I'm storing a version of python in a project directory, and shiboken is supposed to link against that, but it appears to be linking against the python in /Library/Frameworks/Python.framework (which has extra symbols that my project python does not have). The environment.sh script is finding my python, and my python's libraries are on DYLD_LIBRARY_PATH, but shiboken and/or cmake seem to be ignoring them. The build works if I delete my python from /Library/Frameworks/Python.framework.
> I even tried adding:
> -DPYTHON_LIBRARY=/Users/amosa/triad/tools/python/lib/libpython2.7.dylib -DPYTHON_INCLUDE=/Users/amosa/triad/tools/python/include
> to the cmake command in build_and_install, but that didn't help. it printed:
> -- Found PythonLibs: /Users/amosa/triad/tools/python/lib/libpython2.7.dylib (found suitable version "2.7.5", minimum required is "2.6")
> -- Found PythonInterp: /Users/amosa/triad/tools/python/bin/python2.7 (found version "2.7.3")
> I can't explain the version discrepancy (my Frameworks version is 2.7.5, my local version is 2.7.3)

This is a binary incompatibility between Python 2.7.3 and Python 2.7.5. 
  My guess is that your using the headers from 2.7.5, but trying to link 
against 2.7.3.



More information about the PySide mailing list