<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">2013/11/7 Otto Chiu <span dir="ltr"><<a href="mailto:ochiu@teslamotors.com" target="_blank">ochiu@teslamotors.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">






<div link="blue" vlink="purple" lang="EN-US">
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">I have Ubuntu 12.04. Even after running the post install script I am getting ImportError: dynamic module†does not define init function†(PyInit_QtCore). I was
 able to import PySide just fine though.</span></p></div></div></blockquote><div><br></div><div>This bug is now fixed. Please get latest version of pyside-setup scripts from github and try rebuild.<br><br></div><div>-Roman<br>
</div><div>†</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div link="blue" vlink="purple" lang="EN-US"><div><p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u><u></u></span></p>

<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u>†<u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Thanks,<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d">Otto<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:"Calibri","sans-serif";color:#1f497d"><u></u>†<u></u></span></p>
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif"">From:</span></b><span style="font-size:10.0pt;font-family:"Tahoma","sans-serif""> Roman Lacko [mailto:<a href="mailto:backup.rlacko@gmail.com" target="_blank">backup.rlacko@gmail.com</a>]
<br>
<b>Sent:</b> Thursday, November 07, 2013 12:13 AM<br>
<b>To:</b> Otto Chiu<br>
<b>Cc:</b> <a href="mailto:PySide@qt-project.org" target="_blank">PySide@qt-project.org</a><br>
<b>Subject:</b> Re: [PySide] Installing on Ubuntu with python3<u></u><u></u></span></p>
<p class="MsoNormal"><u></u>†<u></u></p>
<div>
<div>
<div>
<p class="MsoNormal">2013/11/7 Otto Chiu <<a href="mailto:ochiu@teslamotors.com" target="_blank">ochiu@teslamotors.com</a>><u></u><u></u></p>
<div>
<div>
<p class="MsoNormal">Hi All,<u></u><u></u></p>
<p class="MsoNormal">I want to see if anybody has anybody has any tips or hints on installing pyside on Ubuntu with python3 in a virtualenv.<u></u><u></u></p>
<p class="MsoNormal">†<u></u><u></u></p>
<p class="MsoNormal">I tried following the instructions here:
<a href="https://pypi.python.org/pypi/PySide#installing-pyside-on-a-unix-system" target="_blank">
https://pypi.python.org/pypi/PySide#installing-pyside-on-a-unix-system</a>, but I keep getting syntax errors when I go install the egg.<u></u><u></u></p>
</div>
</div>
<div>
<p class="MsoNormal"><u></u>†<u></u></p>
</div>
<div>
<p class="MsoNormal">You can ignore the syntax errors when installing the egg, just don't forget to run the post install script:<u></u><u></u></p>
<pre>$ python2.7 pyside_postinstall.py -install<u></u><u></u></pre>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt">BTW, what version of Ubuntu you have ?<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Thanks<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Roman<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><u></u>†<u></u></p>
</div>
<blockquote style="border:none;border-left:solid #cccccc 1.0pt;padding:0in 0in 0in 6.0pt;margin-left:4.8pt;margin-right:0in">
<div>
<div>
<p class="MsoNormal">I also tried
<a href="http://qt-project.org/wiki/PySide_Binaries_Linux" target="_blank">http://qt-project.org/wiki/PySide_Binaries_Linux</a> with the python3-pyside option but python canít find the PySide package.<u></u><u></u></p>
<p class="MsoNormal">†<u></u><u></u></p>
<p class="MsoNormal">Any help is much appreciated.<u></u><u></u></p>
<p class="MsoNormal"><span style="color:#888888">†<u></u><u></u></span></p>
<p class="MsoNormal"><span style="color:#888888">Otto<u></u><u></u></span></p>
</div>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
_______________________________________________<br>
PySide mailing list<br>
<a href="mailto:PySide@qt-project.org" target="_blank">PySide@qt-project.org</a><br>
<a href="http://lists.qt-project.org/mailman/listinfo/pyside" target="_blank">http://lists.qt-project.org/mailman/listinfo/pyside</a><u></u><u></u></p>
</blockquote>
</div>
<p class="MsoNormal"><u></u>†<u></u></p>
</div>
</div>
</div>
</div>

</blockquote></div><br></div></div>