[Qbs] qbs 1.8.1 cannot find Qt.core

Jake Petroules Jake.Petroules at qt.io
Thu Jul 13 23:17:53 CEST 2017


Is there any way in Arch to mark a package version as binary-incompatible with the previous?

> On Jul 13, 2017, at 8:12 AM, Christian Kandeler <christian.kandeler at qt.io> wrote:
> 
> On Mon, 10 Jul 2017 10:24:33 +0200
> Elyzabeth von Reuenthal <elyzabethvonreuenthal at iserlohn-fortress.net> wrote:
> 
>> Ever since I updated to qbs 1.8.1, I get the following message in QtCreator:
>>> Failed to set up kit for Qbs: Setting up Qt profile 'qtc_Desktop_ca73bbd0'
>>> failed: Cannot open file '/usr/lib/QtGui.framework/Headers/qtgui-config.h' (No
>>> such file or directory).  
>> Running qbs directly however doesn't produce any errors and works as expected.
>> 
>> I'm running archlinux, with qbs 1.8.1 and qtcreator 4.3.1.
> 
> Arch Linux has updated the qtcreator package (qtcreator-4.3.1-2), and this one does not seem to have the problem anymore.
> 
> 
> Christian
> _______________________________________________
> Qbs mailing list
> Qbs at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/qbs

-- 
Jake Petroules - jake.petroules at qt.io
The Qt Company - Silicon Valley
Qbs build tool evangelist - qbs.io




More information about the Qbs mailing list