[Qbs] dump-nodes-tree broken?

Christian Gagneraud chgans at gmail.com
Wed Jul 17 14:26:50 CEST 2019

On Wed, 17 Jul 2019 at 23:52, Christian Kandeler
<Christian.Kandeler at qt.io> wrote:
> On Wed, 17 Jul 2019 23:41:54 +1200
> Christian Gagneraud <chgans at gmail.com> wrote:
> > I'm trying to use dump-nodes-tree with qbs 1.13.1 (from QtC), and i
> > get nothing except a message 'Restoring build graph from disk'.
> > I've tried 'qbs dump-nodes-tree' and 'qbs dump-nodes-tree -p
> > qtcreator', still the same..
> > Is there any special things that need to be done prior using it?
> You need to built first. The nodes are not known in advance.

Ahhh! Thanks, it works now.
That's weird really, the build graph is on disk, and this tool 'Dumps
the nodes in the build graph to \c stdout.'.
I was expecting this tool to simply pretty-print the build graph
file.Is there a way to achieve that?

Looking at the output of dump-nodes-tree and the source code, i kind
of start to kind of understand what's going on... :)


More information about the Qbs mailing list