[Qt-creator] Refactoring dangerous behaviour

Yves Bailly yves.bailly at sescoi.fr
Tue Feb 12 08:10:38 CET 2013


Greetings all,

Using QtCreator 2.6.2 with a Qt 4.8.4, I've seen a behaviour while using the
refactoring command which seems a bit dangerous to me.

Let's assume I have two overloads of a method in a class:
int myFunc(char* data);
int myFunc(char* data, char* details);

Pointing on the first "myFunc" and using "refactor" to change its name,
it will *also* change the name of the *second* method. In my case it's
actually the desired behaviour, however I wonder if it's always the
case and if this should/could be made optional in some way.

Assuming there's not already an option for that which I would have not seen.

Anyway, a great thanks to all the creators of this wonderful tool.

Regards,

-- 
      /- Yves Bailly - Software developer   -\
      \- Sescoi R&D  - http://www.sescoi.fr -/
"The possible is done. The impossible is being done. For miracles,
thanks to allow a little delay."



More information about the Qt-creator mailing list