[Qt-creator] Debugging in QtCreator only shows disassembly

israel at eraalaska.net israel at eraalaska.net
Tue Nov 3 22:24:22 CET 2015

I recently upgraded my computer to Mac OS X 10.11 (El Capitan), and Qt to 5.5.1 (from 5.4.1). After overcoming the usual frustration with getting the new application to launch (can't find platform plugin "cocoa" available platforms are: cocoa), I went about trying to debug my latest issue. But there I ran into a problem: Qt Creator isn't showing my code, but only the disassembly. Actually, it's not honoring my breakpoints either, the only way I can get it to go into the debugger at all is to hit the pause button. Once paused, I can see in the call stack the function in my code it is currently executing (I think I have an infinite loop or the like), but I can't see where in the file it is since all it shows is the disassembly. How can I get the debugger working again?

See the attached screen shot for the issue. The calculatePayPeriods() function is one I wrote, defined in the utilities.cpp file. I also tried going back to Qt 5.4 and an older version of Qt Creator, but neither of those helped any.

Israel Brewster
Systems Analyst II
Ravn Alaska
5245 Airport Industrial Rd
Fairbanks, AK 99709
(907) 450-7293

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20151103/10c4f31e/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen Shot 2015-11-03 at 12.00.03 PM.png
Type: image/png
Size: 516879 bytes
Desc: not available
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20151103/10c4f31e/attachment.png>

More information about the Qt-creator mailing list