[Qt-creator] CMake config failure == unfixable

Andy asmaloney at gmail.com
Thu Aug 31 23:25:34 CEST 2017

On Thu, Aug 31, 2017 at 4:37 PM, Tobias Hunger <tobias.hunger at gmail.com>

> Hi Andy,
> Sorry, I left this as a draft and right to send it:-(
> On Aug 29, 2017 20:15, "Andy" <asmaloney at gmail.com> wrote:
> I'm trying to config a relatively complex project with Qt Creator 4.3.1.
> 1. I select a new option - call it "foo".
> 2. It fails to configure because there are new paths to set for "foo".
> 3. I decide to not configure "foo", so I deselect that option from step 1.
> 4. It still fails to configure - with no way to fix it now.
> 5. The "Advanced" checkbox is disabled meaning I can't remove the new
> stuff it added in step 2 to get a working config again.
> 6. I tried to configure it using the CMake application instead, but now
> when I load the project I get a completely blank configuration with errors
> pointing at the paths from step 2.
> You can always ask Creator to throw away the current configuration and
> start over. There is a menu entry to blow away CMakeCache.txt for exactly
> this case:-)

Thanks Tobias.

> Is there a way to avoid using this config interface completely and just
> use the CMake application like we used to do?
> Creator still uses cmake, it just calls it with different parameters:-)

I understand that, but the CMake application (GUI) is much easier to use to
configure a project than the capabilities provided by Creator, so I'd
rather just use it. Is there a way to make it work? When I generate things
that way, I can't get Creator to work with the configuration.

I tried to completely remove my config and copy one from another (working)
kit using the "Copy steps from another kit...", but it doesn't copy the
whole configuration, so I still need to mess around with settings and
sometimes I end up back in the "can't do anything" mode and have to
restart. So I'm pretty frustrated with the built-in cmake config stuff.

(... but I really like Creator overall! :-))
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20170831/2079fad8/attachment.html>

More information about the Qt-creator mailing list