[Qt-creator] Still no help...

Jason H jhihn at gmx.com
Thu May 17 17:08:33 CEST 2018

Thanks, I'll keep you posted. I did what you suggested but I don't currently have the problem. *shrug*

> Sent: Thursday, May 17, 2018 at 2:37 AM
> From: "Nikolai Kosjar" <nikolai.kosjar at qt.io>
> To: "Jason H" <jhihn at gmx.com>, qt-creator <qt-creator at qt-project.org>
> Subject: Re: [Qt-creator] Still no help...
> On 05/16/2018 04:15 PM, Jason H wrote:
> > I have reverted to using the help button on the left pane. Why isn't F1 working?
> > I have help installed.. it works on some projects but not others.
> What do you mean by "help button on the left pane"?
> For which code? (C++? QML/JS?)
> > Is there a way to troubleshoot what fails when I press F1?
> For the clang code model, you can start Qt Creator within a run time 
> environment containing
>    QT_LOGGING_RULES=qtc.clangcodemodel.hover=true
> to see debugging output when doing a mouse hover on e.g. identifiers. 
> This will query the help data base, basically triggering the F1 code 
> path (the tooltip will contain a F1 symbol do indicate that F1 can be 
> pressed to go to documentation). A sucessfull run looks like this:
>    qtc.clangcodemodel.hover: Requesting tooltip info at 68
>    qtc.clangcodemodel.hover: Processing tooltip info "QCoreApplication"
>    qtc.clangcodemodel.hover: Querying help manager with 
> "QCoreApplication" "QCoreApplication" ClassOrNamespace
>    qtc.clangcodemodel.hover:   Match!
> Please put answer to these questions and the failing example into a bug 
> report.
> Note that the clang code model is more sensitive to invalid code than 
> the built-in one. Error recovery is not that great.
> Nikolai

More information about the Qt-creator mailing list