[Qt-creator] QtCreator on F29

Richard Kimberly Heck rikiheck at lyx.org
Tue Jun 25 22:18:50 CEST 2019

On 6/25/19 3:34 PM, André Pönitz wrote:
> On Tue, Jun 25, 2019 at 03:11:56PM -0400, Richard Kimberly Heck wrote:
>> Hi, André! Hope you are well.
>> On 6/19/19 5:10 PM, André Pönitz wrote:
>>> On Fri, Jun 14, 2019 at 10:12:52PM -0400, Richard Kimberly Heck wrote:
>>>> Since upgrading to Fedora 29 (yes, I tend to be a bit behind), I've been
>>>> having problems using QtCreator as I always have to work on LyX.
>>>> Specifically, QtCreator fails to find a lot of included files, with the
>>>> result that there are gazillions of 'parse errors' displayed in the
>>>> editor. For example, our own generated config.h is not found, and
>>>> QtCreator complains that none of the Qt headers are found.
>>>> Any idea what has changed or what I might do? I've tried deleting all
>>>> the *.creator files, etc.
>>> I guess there's more information on the actual versions needed.
>>> I tried current LyX + Qt Creator + Qt (all recent-ish git)
>>> with CMake and it built and run out-of-the-box.
>> This is all on Fedora 29.
>> About QtCreator says:
>> Qt Creator 4.7.2
>> Based on Qt 5.11.3 (GCC 8.2.1 20181215 (Red Hat 8.2.1-6), 64 bit)
>> Qt itself is 5.11.3
>> I've just cloned the LyX git repo into a fresh directory, and I have the
>> same problem. The first and in a way biggest problem is that config.h is
>> not being found. But nor are the Qt headers, still. I'm attaching a
>> screenshot showing what I see.
>> It is possible, of course, that it is a Fedora problem. The problem
>> appeared when I upgraded to F29.
> Is that using CMake or autotools? I noticed that it only works with
> CMake for me, and a lot of not found items when using autotools?

I tried CMake. No luck. Here's what I did:

Fresh clone of LyX
mkdir build
cd build
cmake ..

Opened Qt Creator, imported existing project using all defaults. Still
Qt headers not found.


More information about the Qt-creator mailing list