[Qt-creator] QtCreator on F29

Eike Ziller Eike.Ziller at qt.io
Wed Jun 26 09:35:25 CEST 2019

> On 25. Jun 2019, at 21:36, Richard Kimberly Heck <rikiheck at lyx.org> wrote:
> On 6/25/19 3:11 PM, Richard Kimberly Heck wrote:
>> Hi, André! Hope you are well.
>> On 6/19/19 5:10 PM, André Pönitz wrote:
>>> On Fri, Jun 14, 2019 at 10:12:52PM -0400, Richard Kimberly Heck wrote:
>>>> Since upgrading to Fedora 29 (yes, I tend to be a bit behind), I've been
>>>> having problems using QtCreator as I always have to work on LyX.
>>>> Specifically, QtCreator fails to find a lot of included files, with the
>>>> result that there are gazillions of 'parse errors' displayed in the
>>>> editor. For example, our own generated config.h is not found, and
>>>> QtCreator complains that none of the Qt headers are found.
>>>> Any idea what has changed or what I might do? I've tried deleting all
>>>> the *.creator files, etc.
>>> I guess there's more information on the actual versions needed.
>>> I tried current LyX + Qt Creator + Qt (all recent-ish git)
>>> with CMake and it built and run out-of-the-box.
>> This is all on Fedora 29. 
>> About QtCreator says:
>> Qt Creator 4.7.2
>> Based on Qt 5.11.3 (GCC 8.2.1 20181215 (Red Hat 8.2.1-6), 64 bit)
>> Qt itself is 5.11.3
>> I've just cloned the LyX git repo into a fresh directory, and I have the same problem. The first and in a way biggest problem is that config.h is not being found. But nor are the Qt headers, still. I'm attaching a screenshot showing what I see.
>> It is possible, of course, that it is a Fedora problem. The problem appeared when I upgraded to F29.
> I've just downloaded Qt 4.9.1, and the problem with the Qt headers persists. I also tried deleting (or moving) all of the QtCreator files in ~/.config/. The weird thing is that compilation works fine. It's just in the editor that the errors appear (which then causes all kinds of other problems). For some reason, the Qt headers are just not being found by QtCreator itself. (They are in /usr/include/qt5/.)
> I have checked the "kit" and set the Qt Version to /usr/lib64/qt5/bin/qmake-qt5. This reports Qt version 5.11.3, and the "Details" section gives the expected info.
> How does QtCreator try to find the Qt headers?

Can you please check the details in Tools > C++ > Inspect C++ Code Model ? That shows what the code model knows.

Br, Eike

> Riki
> _______________________________________________
> Qt-creator mailing list
> Qt-creator at qt-project.org
> https://lists.qt-project.org/listinfo/qt-creator

Eike Ziller
Principal Software Engineer

The Qt Company GmbH
Rudower Chaussee 13
D-12489 Berlin
eike.ziller at qt.io
Geschäftsführer: Mika Pälsi,
Juha Varelius, Mika Harjuaho
Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B

More information about the Qt-creator mailing list