[Qt-creator] Code model could not parse, but compiled, iOS Framework

Jason H jhihn at gmx.com
Tue Jan 21 20:59:45 CET 2020

I'm trying to add OpenCV to a mobile app. Works fine on android, but on iOS Qt Creator is tell ing me it can't parse the included file.

In the ios setion of the .pro:
	LIBS += -F$$PWD/ios -framework opencv2
	INCLUDEPATH+=$$PWD/ios/opencv2.framework/Headers  ((should I even need this?))

The app is able to compile though. I copied opencv2.framework from the build location.

I get the red errors in the code edit window of  "use of undeclared identifer 'cv'..."

What do I need to do to make QtC/code model happy? (4.10.2) It seems that the framework directory structure ($$PWD/ios/opencv2.framework/Headers/*.hpp) breaks the #includes of opencv2/*.hpp

I tried to add a symlink:
ln -s $$PWD/ios/opencv2.framework/Headers  $$PWD/ios/opencv2
and changed: INCLUDEPATH+=$$PWD/ios

And that worked, but I don't think I should have to provide a symlink?

How should this work?

More information about the Qt-creator mailing list