<div dir="ltr">Thanks Tobias, that makes sense. You are indeed right: I am using qmake-based projects, which explains why Qt must be in the kit.<div><br></div><div>I'm trying to make it as painless/lightweight as possible for other developers to start using Qt Creator for their non-Qt projects. By the sounds of it, Qt Creator requires either qmake or cmake to be on the developer's PC in order to work. I'm thinking at this point that I might just have developers copy qmake.exe onto their PCs rather than having them download a 400 MB+ Qt library download. Is this a solution you recommend/others have adopted for similar use cases?</div>
<div><br></div><div style>On a related topic, if I do go down the route of just distributing the qmake.exe, will the 32-bit version that comes with Qt 5.0.1 work on a 64-bit Windows PC for the purposes of Qt Creator picking it up as a Qt version in a kit? I'm hoping so, as it'll ease distribution and I also don't see any pre-built versions of Qt for 64-bit Windows.</div>
<div style><br></div><div style>Thanks!</div><div style><br></div><div style>-Alfonso</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Thu, Feb 14, 2013 at 4:43 AM, Tobias Hunger <span dir="ltr"><<a href="mailto:tobias.hunger@digia.com" target="_blank">tobias.hunger@digia.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Alfonso!<br>
<div class="im"><br>
On 14.02.2013 01:38, Alfonso Chartier wrote:<br>
> I tried uninstalling all versions<br>
> of Qt on PC, however it now does not let me configure the project<br>
> because it complains that a valid kit could not be found. The kit I have<br>
> defined is perfectly valid except that "None" shows up for the Qt<br>
> version, as expected.<br>
<br>
</div>Which kind of project are you trying to configure? This sounds like you<br>
are going for one of the qmake-based projects. Those will not work<br>
without a Qt version set since they require qmake which comes as a part<br>
of Qt installation. Most project wizards will use qmake since it is<br>
pretty simple to use and how many Qt apps are build.<br>
<br>
"Non-Qt Project>* (CMake Build)" should work without Qt in a kit though.<br>
<div class="im"><br>
> My question is: is there a way I can configure a kit such that it<br>
> doesn't depend on Qt?<br>
<br>
</div>It is, provided you do not use qmake as a build system.<br>
<div class="im"><br>
> I love Qt Creator and it's a fantastic IDE, I just think removing the Qt<br>
> dependency would make it an IDE that is much easier to adopt for<br>
> non-Qt-based development.<br>
<br>
Thanks!<br>
<br>
</div>Best Regards,<br>
Tobias<br>
<span class="HOEnZb"><font color="#888888"><br>
--<br>
Tobias Hunger, Senior Software Engineer - Digia, Qt<br>
Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin<br>
Geschäftsführer: Mika Pälsi, Juha Varelius, Anja Wasenius<br>
Sitz der Gesellschaft: Berlin. USt-IdNr: DE xxx xxx xxx<br>
Registergericht: Amtsgericht Charlottenburg, HRB 144331 B<br>
</font></span><div class="HOEnZb"><div class="h5">_______________________________________________<br>
Qt-creator mailing list<br>
<a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
<a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" target="_blank">http://lists.qt-project.org/mailman/listinfo/qt-creator</a><br>
</div></div></blockquote></div><br></div>