<div dir="ltr"><div>I installed the .pdb files into the C:\DREAM3D_SDK\Qt5.10.1\5.10.1\msvc2017_64 directory which correctly put all of them into the appropriate sub-directories. I also edited the PATH environment variable for the project to include those directories and I still get the issue. I have reinstalled the Windows 10 SDK (I'm on Windows 10 x64) with VS 2017 latest update) according to <a href="http://doc.qt.io/qtcreator/creator-debugger-engines.html">http://doc.qt.io/qtcreator/creator-debugger-engines.html</a>. I would really like to switch from VS 2017 to QtCreator on Windows ( I use QtCreator on macOS). I'm just not sure what I am doing wrong. I guess I could dig up my Windows 10 serial number and just clean install windows and start over.</div><div><br></div><div>--</div><div>Mike Jackson<br></div></div><div class="gmail_extra"><br clear="all"><div><div class="gmail_signature" data-smartmail="gmail_signature">_________________________________________________________<br>Mike Jackson                  <a href="mailto:mike.jackson@bluequartz.net" target="_blank">mike.jackson@bluequartz.net</a><br>BlueQuartz Software                    <a href="http://www.bluequartz.net" target="_blank">www.bluequartz.net</a><br>Principal Software Engineer                  Dayton, Ohio</div></div>
<br><div class="gmail_quote">On Fri, Jul 13, 2018 at 2:22 PM, Michael Jackson <span dir="ltr"><<a href="mailto:mike.jackson@bluequartz.net" target="_blank">mike.jackson@bluequartz.net</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I don't think I remember ever having to do this with Visual Studio but I'll bite. So I downloaded the pdb zip file? I have Qt 5.10.1 with VS2017 x64. Where do I install the pdb files? My build dir? Or somewhere in the Qt5 installation?<br>
<br>
Thanks<br>
<span class=""><br>
--<br>
Michael Jackson | Owner, President<br>
      BlueQuartz Software<br>
[e] <a href="mailto:mike.jackson@bluequartz.net">mike.jackson@bluequartz.net</a><br>
</span>[w] <a href="http://www.bluequartz.net" rel="noreferrer" target="_blank">www.bluequartz.net</a> <<a href="http://www.bluequartz.net" rel="noreferrer" target="_blank">http://www.bluequartz.net</a>><br>
<div class="HOEnZb"><div class="h5"><br>
On 7/13/18, 12:38 PM, "Qt-creator on behalf of Bob Hood" <qt-creator-bounces+mike.<wbr>jackson=<a href="mailto:bluequartz.net@qt-project.org">bluequartz.net@qt-<wbr>project.org</a> on behalf of <a href="mailto:bhood2@comcast.net">bhood2@comcast.net</a>> wrote:<br>
<br>
    Ah!  That was indeed the problem (and hopefully Micheal's as well).  My debug\ <br>
    folder had Qt5 DLLs sitting in it, because I mistakenly assumed they had to be <br>
    there in order for debugging to work.  When I deleted them, Creator used the <br>
    kit path, and found the *.pdb file it needed.  I can now see QStrings.<br>
<br>
    This was pilot error.  Creator was not at fault.  Sorry for the noise.<br>
<br>
<br>
    On 7/12/2018 11:12 PM, David Schulz wrote:<br>
    > Hi,<br>
    ><br>
    > cdb can't find the pdb file for W:\Dev\Personal\Projects\Qt\<wbr>Skoop\client\debug\Qt5Cored.<wbr>dll. Do you know where that file is on your hard disk?<br>
    ><br>
    > And please create a  bug report for this issue, so we can move the discussion to jira.<br>
    ><br>
    > Greetings<br>
    > David<br>
    ><br>
    > -----Original Message-----<br>
    > From: Qt-creator [mailto:<a href="mailto:qt-creator-bounces%2Bdavid.schulz">qt-creator-bounces+<wbr>david.schulz</a>=<a href="mailto:qt.io@qt-project.org">qt.io@qt-project.<wbr>org</a>] On Behalf Of Bob Hood<br>
    > Sent: Friday, July 13, 2018 04:30<br>
    > To: <a href="mailto:qt-creator@qt-project.org">qt-creator@qt-project.org</a><br>
    > Subject: Re: [Qt-creator] QString "not accessible" in Creator 4.6.2?<br>
    ><br>
    > <a href="https://pastebin.com/z2eZxVuu" rel="noreferrer" target="_blank">https://pastebin.com/z2eZxVuu</a><br>
    ><br>
    ><br>
    > On 7/9/2018 5:10 AM, David Schulz wrote:<br>
    >> Hi,<br>
    >><br>
    >> I've checked 4.6.2 and 4.7 with a Qt based on msvc 2017 WindowsSDKVersion 10.0.17134.0 and I get sensible dumper values in the locals and expression view.<br>
    >> Can you share the content of the debugger log (Window > Views > Debugger Log) on your codepaster of choice?<br>
    >>    <br>
    >> Greetings<br>
    >> David<br>
    >><br>
    >> -----Original Message-----<br>
    >> From: Qt-creator [mailto:<a href="mailto:qt-creator-bounces%2Bdavid.schulz">qt-creator-bounces+<wbr>david.schulz</a>=<a href="mailto:qt.io@qt-project.org">qt.io@qt-project.<wbr>org</a>] On Behalf Of Bob Hood<br>
    >> Sent: Saturday, July 7, 2018 15:36<br>
    >> To: <a href="mailto:qt-creator@qt-project.org">qt-creator@qt-project.org</a><br>
    >> Subject: Re: [Qt-creator] QString "not accessible" in Creator 4.6.2?<br>
    >><br>
    >> So only Michael and I are experiencing this?  Or is that only Michael and I are using 4.6.2 on Windows?<br>
    >><br>
    >><br>
    >> On 7/6/2018 6:08 AM, Michael Jackson wrote:<br>
    >>> I also just happened to setup QtCreator 4.6.2 and I had the same issue. Latest VS2017 release running on Windows 10 x64.<br>
    >>> --<br>
    >>> Michael Jackson | Owner, President<br>
    >>>          BlueQuartz Software<br>
    >>> [e] <a href="mailto:mike.jackson@bluequartz.net">mike.jackson@bluequartz.net</a><br>
    >>> [w] <a href="http://www.bluequartz.net" rel="noreferrer" target="_blank">www.bluequartz.net</a><br>
    >>><br>
    >>> On 7/5/18, 6:49 PM, "Qt-creator on behalf of Bob Hood" <qt-creator-bounces+mike.<wbr>jackson=<a href="mailto:bluequartz.net@qt-project.org">bluequartz.net@qt-<wbr>project.org</a> on behalf of <a href="mailto:bhood2@comcast.net">bhood2@comcast.net</a>> wrote:<br>
    >>><br>
    >>>        I have installed Creator 4.6.2 (normally, I use 4.0.3) and have started a new<br>
    >>>        project with it.  Prior to installing it, I already had Visual Studio 2017<br>
    >>>        15.4.7 installed, along with Windows SDK v10.1.17134.12 with "Debugging Tools<br>
    >>>        for Windows".  Creator 4.6.2 automatically found the debugging tools, and I<br>
    >>>        reconfigured my Kits accordingly for use with Qt 5.9.4 Desktop (which I built<br>
    >>>        myself using Visual Studio 2017, so they are ABI compatible).<br>
    >>>        <br>
    >>>        I'm debugging into my Qt application, and I'm getting "not accessible" the<br>
    >>>        Locals pane for QString and QStringList.  Was there some further set-up I<br>
    >>>        needed to perform?  I don't recall having this issue with 4.0.3.<br>
    >>>        ______________________________<wbr>_________________<br>
    >>>        Qt-creator mailing list<br>
    >>>        <a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
    >>>        <a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" rel="noreferrer" target="_blank">http://lists.qt-project.org/<wbr>mailman/listinfo/qt-creator</a><br>
    >>>        <br>
    >>><br>
    >>><br>
    >>> ______________________________<wbr>_________________<br>
    >>> Qt-creator mailing list<br>
    >>> <a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
    >>> <a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" rel="noreferrer" target="_blank">http://lists.qt-project.org/<wbr>mailman/listinfo/qt-creator</a><br>
    >> ______________________________<wbr>_________________<br>
    >> Qt-creator mailing list<br>
    >> <a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
    >> <a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" rel="noreferrer" target="_blank">http://lists.qt-project.org/<wbr>mailman/listinfo/qt-creator</a><br>
    >> ______________________________<wbr>_________________<br>
    >> Qt-creator mailing list<br>
    >> <a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
    >> <a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" rel="noreferrer" target="_blank">http://lists.qt-project.org/<wbr>mailman/listinfo/qt-creator</a><br>
    > ______________________________<wbr>_________________<br>
    > Qt-creator mailing list<br>
    > <a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
    > <a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" rel="noreferrer" target="_blank">http://lists.qt-project.org/<wbr>mailman/listinfo/qt-creator</a><br>
<br>
    ______________________________<wbr>_________________<br>
    Qt-creator mailing list<br>
    <a href="mailto:Qt-creator@qt-project.org">Qt-creator@qt-project.org</a><br>
    <a href="http://lists.qt-project.org/mailman/listinfo/qt-creator" rel="noreferrer" target="_blank">http://lists.qt-project.org/<wbr>mailman/listinfo/qt-creator</a><br>
<br>
<br>
<br>
</div></div></blockquote></div><br></div>