[Qtwebengine] BUG: arguments to dbus_connection_dispatch() were incorrect

Kevin Truong knt261 at gmail.com
Wed Mar 9 02:46:53 CET 2016

Hi staff,

I am using Qt WebEngine on a new machine. It didn't have problems with the
previous machines, but on the new machine when I run a Qt WebEngine
program, it outputs this error in the terminal:

process 30346: arguments to dbus_connection_dispatch() were incorrect,
assertion "connection != NULL" failed in
file ../../dbus/dbus-connection.c line 4559.
This is normally a bug in some application using the D-Bus library.

The program still runs fine and everything is rendered correctly, although
it seems much slower. I confirmed this is due to the QT code because when I
comment out anything that uses QtApplication, this message stops being

I built Qt5 and Qt WebEngine via the github repo (
https://github.com/qtproject/qt5), and tried both versions 5.6 and 5.5. The
machine I am using is ubuntu.

uname -a:
Linux test-render3 3.19.0-51-generic #57-Ubuntu SMP Fri Feb 19 14:05:05 UTC
2016 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:        15.04
Codename:       vivid

Any ideas how to fix this D-bus bug?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qtwebengine/attachments/20160308/8204fbc4/attachment.html>

More information about the QtWebEngine mailing list