[Qtwebengine] Loading widevine via ppapi-widevine-path

Mike Nolan me at mknln.com
Thu Sep 22 00:17:05 CEST 2016

Hi all,

When I try to load my application via


I get an error upon trying to use Widevine

  [0921/164137:ppapi_thread.cc(331)] Failed to load Pepper module from
/usr/lib/ppapi-plugins/libwidevinecdmadapter.so: cannot open shared
object file: Operation not permitted

At first I figured it was permissions, so I tried to set them to 777, as a
start. That didn't fix it, so then I tried to mv
/opt/google/chrome/libwidevinecdmadapter.so to
/opt/google/chrome/libwidevinecdmadapter.so.bak and pass it in.


Same error!

So at this point I'm wondering if this is just not working. Is anyone
willing to try? Maybe it's a dumb error I'm making as well, but I can't
see it.

Note that it works fine when I don't try to use --ppapi-widevine-path and
instead let it read from the default path of
/opt/google/chrome/libwidevinecdmadapter.so. Netflix and other DRM content

I'm doing this from the v5.7.0 branch of QtWebengine, on Linux.


More information about the QtWebEngine mailing list