[Qtwebengine] QWebengine on ARMv8

Mohammad Moradi mohammads_32 at yahoo.com
Thu Feb 2 14:44:38 CET 2017

I tried to solve * this error*. But I still couldn't get ride of that.Is this bug related to qtwebengine 5.7.0 in case of cross compiling? or missed some dependency on RPi3?*the error is @line 105
Thank you

    On Tuesday, January 31, 2017 8:12 PM, Mohammad Moradi <mohammads_32 at yahoo.com> wrote:

 Hi AllanI guess the errors related to arch has been solved by adding arm_fpu=\"\" to the GYP_CONFIG. However I still don't know what is it doing.
For now, I have to fix this problem :(http://pastebin.com/6YF0Y0uf


    On Tuesday, January 31, 2017 6:13 PM, Allan Sandfeld Jensen <allan.jensen at qt.io> wrote:

 On Tuesday 31 January 2017, Allan Sandfeld Jensen wrote:
> On Tuesday 31 January 2017, Mohammad Moradi via QtWebEngine wrote:
> > Hello everybody
> > 
> >  I'm about to build qtwebengine 5.7.0 from sources for RPi3.But it seems
> > 
> > the chromium doesn't support armv8!.Is there anyway to have qwebengine on
> > Pi3?I just want to run some java scripts(pdf viewer plugin). *I tried
> > cross compiling*
> > Thank you
> You could probably change gyp_run.pro and set arm_version=7 or fix Chromium
> in src/3rdparty/chromium/build/common.gypi (look for the line matching
> arm_version to either 6 or 7 but not 8.
Though it probably wouldn't be necessary to change this if you had set an mfpu 
compiler flag to go with the march flag. Like -march=armv8-a -mfpu=neon-fp-
armv8 for some reason architecture flags on ARM doesn't imply otherwise 
mandatory "fpu" features.

The Qt Company
Rudower Chausse 13, 12489 D-Berlin
QtWebEngine mailing list
QtWebEngine at qt-project.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qtwebengine/attachments/20170202/a97d40ec/attachment.html>

More information about the QtWebEngine mailing list