[Qtwebengine] Developer tools debugging not working in Qt 5.12.8

Goldberg, Ilya (DWFN) Ilya.Goldberg at smithsdetection.com
Wed May 6 18:36:47 CEST 2020

Hello Kirill,

Thank you for your response.

I've tried suggested navigation away to another url and back to the debugging page.
Unfortunately, it has no effect. Still having an empty source of the debugging page.

Tried it in both simplebrowser application (based on chromium 69) and Chrome (version 75).

I didn't have chance to try "setInspectedPage" inside simplebrowser application.
There is no such method in the WebView and also the actual page is coming via a WebSocket in the devtools, so I am not sure how to access it from within simplebrowser application.


Message: 2
Date: Tue, 5 May 2020 14:46:39 +0000
From: Kirill Burtsev <kirill.burtsev at qt.io>
To: "qtwebengine at lists.qt-project.org"
        <qtwebengine at lists.qt-project.org>
Subject: Re: [Qtwebengine] Developer tools debugging not working in Qt
        <AM0PR02MB36200BE26DACB1326AA212DF91A70 at AM0PR02MB3620.eurprd02.prod.outlook.com>

Content-Type: text/plain; charset="us-ascii"

Reminds me of QTBUG-80067. So it seems to be a devtools issue in v69.
And the workaround is to just (after attaching through remote debugging) navigate away to some other url and back again.

Other than that, it should be pretty easy to just create separate view and use setInspectedPage inside application itself. This is implemented in simplebrowser example.

Hope this helps.

From: QtWebEngine <qtwebengine-bounces at lists.qt-project.org> on behalf of Goldberg, Ilya (DWFN) <Ilya.Goldberg at smithsdetection.com>
Sent: Monday, May 4, 2020 19:07
To: qtwebengine at lists.qt-project.org
Subject: Re: [Qtwebengine] Developer tools debugging not working in Qt 5.12.8

Hi Kirill,

Thank you for your prompt response.
It was very helpful.
I've tried using simplebrowser example which I've build using the same version of WebEngine from Qt 5.12.8 (chromium V69...).
I can now see the actual pages via the debugging port!
Only a single problem remains, I can open and see in Sources of the Devtools any script apart from the actual top level page that has been loaded. So, cannot debug the actual web page.
I can see the source of the top page in the Network section under Response but not under Sources. It is just remains to be blank.

Have you seen something like that or anybody else reported it?


PROPRIETARY: This e-mail contains proprietary information some or all of which may be legally privileged. It is intended for the recipient only. If an addressing or transmission error has misdirected this e-mail, please notify the author by replying to this e-mail. If you are not the intended recipient you must not use, disclose, distribute, copy, print, or rely on this e-mail.

More information about the QtWebEngine mailing list