[Development] important: upcoming rename of _qpa.h to _p.h

Girish Ramakrishnan girish at forwardbias.in
Tue May 8 12:07:55 CEST 2012

On Fri, May 4, 2012 at 8:20 AM, Girish Ramakrishnan
<girish at forwardbias.in> wrote:
> On Fri, Apr 20, 2012 at 7:16 AM, Girish Ramakrishnan
> <girish at forwardbias.in> wrote:
>> 2012/4/20 Stephen Kelly <stephen.kelly at kdab.com>:
>>> On Friday, April 20, 2012 07:35:39 lars.knoll at nokia.com wrote:
>>>> Proposal sounds ok to me as well. If someone still has concerns, please
>>>> speak up.
>>> I lost track of what the proposal currently is. Could it be restated?
>> 1. We drop _qpa completely. So, it would become qplatformbackingstore.h
>> 2. We teach syncqt that qplatform* is special and we move them all to
>> a special qpa/ directory. So, instead of #include
>> <QtGui/private/qplatformbackingstore.h>, it will be #include
>> <QtGui/qpa/qplatformbackingstore.h>
>> 3. We teach syncqt to create <QtGui/QPA> or #include <QPA> headers. (I
>> think we need the latter since qpa headers are not restricted to gui)
>> 4. We teach the world that qpa is not meant for apps.
>> 5. Add a more benign header pointing out the fact that these files are
>> qpa files.
>> 6. Rename the handle() to platformXXX() since it's easy to educate
>> that anything that has platform in it is out of reach of app
>> developers.
> The change is ready at
> https://codereview.qt-project.org/#change,23443. It implements 1,2
> above. It awaits gunnar/paul's final input.
> The change is source compatible, all plugins should continue to
> compile after the change with no changes.

The change landed. For some reason, the ci is failing compile in all
other modules. Works locally with shadow builds but not on CI. I am on


More information about the Development mailing list