[Development] qpa api - current status

Jørgen Lind jorgen.lind at nokia.com
Tue May 29 08:22:09 CEST 2012

> 6. Rename the handle() to platformXXX() since it's easy to educate
> that anything that has platform in it is out of reach of app
> developers.
> Status: In progress, I am atm, marking handle() as obsolete and as an
> alias to platformXXX().

But since when did the word handle() mean anything else in API design?
Im all for clear and verbose function names, but think this is just
making the api ugly. To me if you ask for a handle of a class you will
get the underlying structure. It then should be crystal clear to the
developer that this class can not be used as a public class.


More information about the Development mailing list