[Development] renaming all QWindow properties that have "window" in them

Thiago Macieira thiago.macieira at intel.com
Fri Oct 19 23:43:52 CEST 2012

On sexta-feira, 19 de outubro de 2012 22.18.25, Shawn Rutledge wrote:
> So pos is bad because it's abbreviated.  And I suspect we may have
> problems with renaming windowState to state, because in QML that
> usually refers to the state-machine state (driving animated
> transitions etc.)  Should we be inconsistent and leave that one as
> windowState then?

The name "state" is also very generic, so that's a candidate for not being 
used. We need descriptive names that convey meaning and aren't ambiguous. That 
one doesn't fit the bill. For example, QAbstractSocket has a state() property 
that returns an enum of type SocketStatus. To be honest, socketState() might 
have made more sense, as QSslSocket later overloads that with the "encryption 

Whether the other ones like "title" make sense without the "window" prefix, you 
need to decide. Is it unambiguous what that title is referring to? How about 
the modality? Do people usually refer to it as the "window modality"? Food for 

Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel Open Source Technology Center
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.qt-project.org/pipermail/development/attachments/20121019/af88184d/attachment.sig>

More information about the Development mailing list