[Development] Setting a Minimum Support OpenSSL Version

Peter Hartmann phartmann at blackberry.com
Tue Aug 6 14:26:46 CEST 2013

On 08/01/2013 05:47 PM, Thiago Macieira wrote:
> (...)
> Consider the decision made: Qt 5.2 will require OpenSSL 1.0 as a minimum
> version.

patch to the documentation: https://codereview.qt-project.org/62311

All CI machines are already using version 1.0.*, except for one 10.04 
Ubuntu machine in the CI system, which might be phased out at some point 
(Tony knows more).
Also, Iikka E. from release management has been contacted so that the 
machines used to create binary packages will use the newer OpenSSL 
version as well, in time for 5.2.

As written before, patches for OpenSSL >= 0.9.7 and < 1.0.0 will still 
be accepted (for some time; for how long exactly will be another 


> _______________________________________________
> Development mailing list
> Development at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/development

This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

More information about the Development mailing list