[Development] Minimum CUPS version vs RHEL 5 support

Thiago Macieira thiago.macieira at intel.com
Thu Dec 12 04:23:08 CET 2013

On quinta-feira, 12 de dezembro de 2013 00:09:52, John Layt wrote:
> Hi,
> I'm refactoring the CUPS printing code (more on that in another email)
> and noticed we don't currently have a minimum required version set,
> i.e. we're currently restricted to the 1.0 api released in 1999.  CUPS
> is now at 1.7.  There's some nicer api I'd like to use from 1.2 and
> 1.4, so for Qt 5.3 I want to set a minimum version of 1.4, which was
> released in 2008 and adopted by most Linux distros in 2009/2010.
> The problem comes with RHEL.  RHEL 6 has CUPS 1.4, but RHEL 5 only has
> 1.3.  I note on http://qt.digia.com/Product/Supported-Platforms/ that
> RHEL 5 is shown as a secondary supported platform in 5.1, albeit using
> a number of self-built unsupported packages.  Any change to require
> CUPS 1.4 would effectively render RHEL 5 unsupported, or at least
> without the option of printing support.
> Would this be acceptable, or should I only set the minimum at 1.3?

RHEL 5.x also currently comes with GCC 4.1.2 and no XCB.

Anyone who wants to deploy Qt 5.3 on that distribution has to compile their 
own compiler and possibly update X, to start with. Updating CUPS should not be 
an issue. Or they can throw money at one of the consulting companies to do it 
for them.

I'd look more towards what RHEL 6 has, since it's more relevant.

Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel Open Source Technology Center
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.qt-project.org/pipermail/development/attachments/20131211/fa17edf3/attachment.sig>

More information about the Development mailing list