[Development] Minimum CUPS version vs RHEL 5 support

John Layt jlayt at kde.org
Thu Dec 12 00:09:52 CET 2013


I'm refactoring the CUPS printing code (more on that in another email)
and noticed we don't currently have a minimum required version set,
i.e. we're currently restricted to the 1.0 api released in 1999.  CUPS
is now at 1.7.  There's some nicer api I'd like to use from 1.2 and
1.4, so for Qt 5.3 I want to set a minimum version of 1.4, which was
released in 2008 and adopted by most Linux distros in 2009/2010.

The problem comes with RHEL.  RHEL 6 has CUPS 1.4, but RHEL 5 only has
1.3.  I note on http://qt.digia.com/Product/Supported-Platforms/ that
RHEL 5 is shown as a secondary supported platform in 5.1, albeit using
a number of self-built unsupported packages.  Any change to require
CUPS 1.4 would effectively render RHEL 5 unsupported, or at least
without the option of printing support.

Would this be acceptable, or should I only set the minimum at 1.3?



More information about the Development mailing list