[Development] QNetworkRequest autoDecompress public API review
markus at woboq.com
Tue Jun 18 16:57:37 CEST 2013
On 18.06.13 16:54, Simon Hausmann wrote:
> On Tuesday 18. June 2013 10.57.57 Jonas Gastal wrote:
>> bool autoDecompress() const;
>> void setAutoDecompress(bool autoDecompress);
> I'm not sure a verb is a good idea for a C++ property name, for example
> req->autoDecompress() reads like it would _do_ something, when it's actually
> just a getter.
> Does this have to be a standalone property, or would it fit into the Attribute
> enum? Alternatively, perhaps the "is" prefix could be used here?
I'd also vote for a QNetworkRequest attribute.
Let's not have too many symbols in the classes.
Maybe even make the name more specific by having "HTTP" inside it?
And maybe with "should" since it is for the request, "is" sounds like a
fact that is already decided.
More information about the Development