[Development] QNetworkRequest autoDecompress public API review

Peter Hartmann phartmann at blackberry.com
Tue Jun 18 16:58:11 CEST 2013

On 06/18/2013 04:54 PM, Simon Hausmann wrote:
> I'm not sure a verb is a good idea for a C++ property name, for example
> req->autoDecompress() reads like it would_do_  something, when it's actually
> just a getter.
> Does this have to be a standalone property, or would it fit into the Attribute
> enum? Alternatively, perhaps the "is" prefix could be used here?

actually my personal preference would also be an enum value enabled via 
setAttribute(), because that is how we control other features as well 
(pipelining, caching, cookies...).


This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

More information about the Development mailing list