[Development] Qt5 can't show some Chinese character?

Konstantin Ritt ritt.ks at gmail.com
Thu Mar 28 13:10:47 CET 2013


This is not a correct way the bugs should be reported ;)

Plz check if this bug is still reproducible with Qt 5.1 sources ("stable"
branch) and fill a bug report at bugreports.qt-project.org/ if so.
Also plz specify if this is a regression since 4.8.
Attaching some minimal code sample that shows the issue is also very
helpful. However, in you (specific) case, attaching a sample string + used
font name + "correct result" and "current result" images would be quite
enough.

BTW, I can't reproduce this issue with Qt 5.1 on windows with "Kozuka
Mincho Pro" font (see attachment)

Regards,
Konstantin

2013/3/28 Yuchen Deng <loaden at gmail.com>

>  Hi, there!
> I wan't show some Chinese character in QTableView, like this:
>
> [image: 内嵌图片 1]
>
> It's should display '霍映心', but it not. why?
> And seems the fonts is not clear?
> Am I missing something?
> I build Qt 5.0.2 with myself on Ubuntu 12.04 64bit.
> Any comments?
>
> --
> Best Regards
> Yuchen
>
> _______________________________________________
> Development mailing list
> Development at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/development
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20130328/9cedd275/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kozuka.png
Type: image/png
Size: 1327 bytes
Desc: not available
URL: <http://lists.qt-project.org/pipermail/development/attachments/20130328/9cedd275/attachment.png>


More information about the Development mailing list