[Development] Setup QT creator for developing QT apps on wandboard-Error

Ch'Gans chgans at gna.org
Tue Jul 29 12:33:48 CEST 2014

On 29/07/14 18:44, Nilesh Kokane wrote:
> Hi Christian,
> First of all thanks for your valuable reply.
> Based on your  suggestion I pinged the board with the boards ip address
> which i found it from the serial console
> $ ping

Hi Nilesh, is your local network node, so it's very unlikely it will ever 
failed. This is all very basic Unix/networking knowledge...

You need to find out the IP address of your board, I don't know how your 
computer is setup, nor do I know how your board is. So I'm sorry but I 
can't help you on that one

> gave success
> Also i pinged the host PC trough the board with
> $ ping
> Gave success

Forget about this is not what you are after.

> But with SSH from the host
> $ ssh root at <mailto:root at>
> Connecting to host...
> SSH connection failure: Connection refused

Forget about that one too...

> $ find
> /home/minda/bin/fsl-community-bsp/build/tmp/sysroots/wandboard-solo
> -name libicui18n.so.51 -o -name libz.so.1
> /tmp/sysroots/wandboard-solo -name libicui18n.so.51 -o -name libz.so.1
> /home/minda/bin/fsl-community-bsp/build/tmp/sysroots/wandboard-solo/lib/libz.so.1
> /home/minda/bin/fsl-community-bsp/build/tmp/sysroots/wandboard-solo/usr/lib/libicui18n.so.51

Interesting, can you try this then:
$ find 
-name 'libQt*'

> What does this command gives?
> $ sh -x ./qtcreator.sh
> + source
> /opt/poky/1.4.1/environment-setup-armv7a-vfp-neon-poky-linux-gnueabi
> ./qtcreator.sh: 2: ./qtcreator.sh: source: not found

Not good, in a previous email you mentioned /opt/poky/1.6.1/..., and now 
it seems to be /opt/poky/1.4.1/...

Which version of Poky are you really using?

One key question you need to ask yourself is whether you need Qt4 or 
Qt5. Can you answer that?

If you keep changing your environment all the time, we won't be able to 
help, you might be interested in this FAQ: 


> Have you tried the "bitbake meta-toolchain-qt5" command?
> No i didn't tried ,can you please provide the step for that

Try this:
$ cd /home/minda/bin/fsl-community-bsp/
$ bitbake meta-toolchain-qt5


////////// Parser ///////////
#define fL1S(s) QString::fromLatin1(s)
namespace { // MSVC2010 doesn't seem to know the semantics of "static" ...

More information about the Development mailing list