[Development] openssl + windows + qtwebkit segmentation fault

Richard Gerd Kuesters richard at humantech.com.br
Wed Oct 8 15:58:22 CEST 2014

Hello all!

I'm having a problem when using qtwebkit with openssl enabled (linked to 
the lib I compiled myself).

Someone have the same problem in the forums, without answer: 

Basically the problem consists on running a qt application in debug 
mode. the webview works fine, shows any https site and even clicks goes 
on but, when hitting any keyboard key in a form, the app gets a segfault.

This problem doesn't shows up if I run the app in release mode. I do 
have openssl compiled with and without debug symbols, and tested a lot 
of combinations, all leading to the same error.

Does Qt needs to be compiled against a debug release of openssl binaries 
to work in debug mode or something?

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20141008/66d6691b/attachment.html>

More information about the Development mailing list