[Development] openssl + windows + qtwebkit segmentation fault

Michael BrĂ¼ning michael.bruning at theqtcompany.com
Wed Oct 8 16:25:11 CEST 2014

Hi Richard,

On 10/08/2014 03:58 PM, Richard Gerd Kuesters wrote:
> Hello all!
> I'm having a problem when using qtwebkit with openssl enabled (linked 
> to the lib I compiled myself).
> Someone have the same problem in the forums, without answer: 
> http://qt-project.org/forums/viewthread/46132/
> Basically the problem consists on running a qt application in debug 
> mode. the webview works fine, shows any https site and even clicks 
> goes on but, when hitting any keyboard key in a form, the app gets a 
> segfault.
The application seems to be hitting an ASSERT, which is only active in 
debug mode.
> This problem doesn't shows up if I run the app in release mode. I do 
> have openssl compiled with and without debug symbols, and tested a lot 
> of combinations, all leading to the same error.
> Does Qt needs to be compiled against a debug release of openssl 
> binaries to work in debug mode or something?
I do not think that OpenSSL has anything to do with the ASSERT, since 
that happens in the RenderLayerCompositor. There has been some fixes to 
these ASSERTs recently for Qt 5.4, so it might be worth checking with 
the beta once it is out. Should it still be present, please file a bug 
report using the "Create Issue" link on this page: 

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20141008/3e63a5e5/attachment.html>

More information about the Development mailing list