[Development] Qt3D on iOS

Sean Harmer sean.harmer at kdab.com
Thu Oct 16 18:49:56 CEST 2014


On 16/10/2014 17:37, Svenn-Arne Dragly wrote:
> Hi,
> Does the current development version of Qt3D 1.0 (master) or Qt3D 2.0 
> (wip/newapi) build on iOS? We tried building both versions, but we get 
> the following error with Qt3D 1.0:
> No rule to make target 
> `/repos/qt3d/build-qt3d-wip-Release/lib/libQt53D.a', needed by 
> `../../lib/libQt53DQuick.dylib'.
> We tried to use the wip/newapi branch to see if Qt3D 2.0 works, but 
> still get a similar error:
> No rule to make target 
> `/repos/qt3d/build-qt3d-wip-Release/lib/libQt53DCore.a', needed by 
> `../../lib/libQt53DRenderer.5.4.0.dylib'.
> This seems to be some kind of linker error that is specific to iOS, as 
> the project builds fine on Mac OS X. However, except for a few minor 
> quirks, the master branch seems to build fine if we comment out 
> "SUBDIRS += quick3d imports" in src.pro.
> Has anyone else been experiencing this or do you have any suggestions 
> on how to debug this issue?
> We have been building the project via Qt Creator 3.2.1 on Mac OS X 
> 10.9 with Qt 5.3.1

We've not started testing Qt3D 2.0 on iOS yet but we will do shortly. If 
you wish to help out with this that would be very much appreciated. I 
don't know if James has made any attempt to build Qt3D on iOS yet or not.

Qt3D wip/newapi branch requires to use dev or 5.4 branches of qtbase and 

The master branch of qt3d is effectively dead.

Kind regards,


Dr Sean Harmer | sean.harmer at kdab.com | Managing Director UK
Klarälvdalens Datakonsult AB, a KDAB Group company
Tel. Sweden (HQ) +46-563-540090, USA +1-866-777-KDAB(5322)
KDAB - Qt Experts - Platform-independent software solutions

More information about the Development mailing list