[Development] Qt3D on iOS

Svenn-Arne Dragly s at dragly.com
Thu Oct 16 18:37:35 CEST 2014


Does the current development version of Qt3D 1.0 (master) or Qt3D 2.0 
(wip/newapi) build on iOS? We tried building both versions, but we get 
the following error with Qt3D 1.0:

No rule to make target 
`/repos/qt3d/build-qt3d-wip-Release/lib/libQt53D.a', needed by 

We tried to use the wip/newapi branch to see if Qt3D 2.0 works, but 
still get a similar error:

No rule to make target 
`/repos/qt3d/build-qt3d-wip-Release/lib/libQt53DCore.a', needed by 

This seems to be some kind of linker error that is specific to iOS, as 
the project builds fine on Mac OS X. However, except for a few minor 
quirks, the master branch seems to build fine if we comment out "SUBDIRS 
+= quick3d imports" in src.pro.

Has anyone else been experiencing this or do you have any suggestions on 
how to debug this issue?

We have been building the project via Qt Creator 3.2.1 on Mac OS X 10.9 
with Qt 5.3.1

Best regards
Svenn-Arne Dragly

More information about the Development mailing list