[Development] No Change-Id being generated for commit message

Thiago Macieira thiago.macieira at intel.com
Thu Mar 26 21:34:14 CET 2015

On Thursday 26 March 2015 12:07:41 Mandeep Sandhu wrote:
> On Thu, Mar 26, 2015 at 10:44 AM, Mandeep Sandhu
> <mandeepsandhu.chd at gmail.com> wrote:
> >>  3) it removes any comment lines
> > 
> > COMMIT_EDITMSG has _only_ comment lines (i.e lines starting with a #),
> > so won't sed remove _all_ lines from it then? (this is exactly what
> > I'm seeing when I run the commit-msg script on COMMIT_EDITMSG).
> So I looked at another (non-qt) repository and noted that the
> COMMIT_EDITMSG contains the last commit message. Is that how it's
> supposed to be?
> For my qt repo, somehow the COMMIT_EDITMSG is only commented line of
> the template. Thats why commit-msg script returns an empty string. I
> changed the sed exp to Not remove lines beginning with # and it
> generated the Change-Id string fine.

It's supposed to contain the text that the editor was last launched with. If 
you tried to make a commit and didn't save anything, that's what you'll see in 
that file.

Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel Open Source Technology Center

More information about the Development mailing list